Back to overview
Resolved

Canadian hosting infrastructure outage

Jul 10, 2026 at 12:22pm UTC
Affected services
Infrastructure — Canada

Resolved
Jul 10, 2026 at 1:26pm UTC

Our Canadian hosting infrastructure is fully operational again. Sign-in and document access are back to normal. No data was affected. Thank you for your patience.

Created
Jul 10, 2026 at 12:22pm UTC

We're experiencing an outage of our Canadian hosting infrastructure, which may prevent sign-in and access to documents. The issue originates from our hosting provider; our team is actively working on a resolution.